poj 1251 Jungle Roads 【prim || kruskal】
题目链接:http://poj.org/problem?id=1251
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 32203 | Accepted: 15063 |
Description
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30
题意:将所有点连通的最低花费!简单展示两种解法!
(1)prim算法
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 110;
const int inf = 0x3f3f3f3f;
int dis[maxn],vis[maxn];
int m[maxn][maxn],n,b,d;
char a,c;
void prim()
{
memset(vis,0,sizeof vis);
for(int i=1;i<=n;i++)
dis[i]=m[1][i];
vis[1] = 1;
int ans,ans1=0,next;
for(int i=1;i<n;i++)
{
ans = inf;
for(int j=1;j<=n;j++)
{
if(!vis[j] && dis[j] < ans)
{
ans = dis[j];
next = j;
}
}
ans1+=ans;
vis[next] = 1;
for(int j=1;j<=n;j++)
{
if(!vis[j] && dis[j] > m[next][j])
dis[j] = m[next][j];
}
}
cout<<ans1<<endl;
}
int main()
{
while(cin>>n && n)
{
memset(m,inf,sizeof m);
for(int i=1;i<n;i++)
{
cin>>a>>b;
while(b--)
{
cin>>c>>d;
m[a-'A'+1][c-'A'+1]=m[c-'A'+1][a-'A'+1]= d;
}
}
prim();
}
return 0;
}
(2)kruskal算法
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e4+10;
int pre[maxn],n,m,a1,b1,c,d;
char a,b;
struct inp{
int x;
int y;
int w;
}p[maxn];
int find(int x)
{
if(pre[x] == x)
return x;
else
return find(pre[x]);
}
void join(int x,int y)
{
int fx = find(x);
int fy = find(y);
if(fx != fy)
pre[fx] = fy;
}
bool cmp(inp a,inp b)
{
return a.w<b.w;
}
int main()
{
while(cin>>n && n)
{
for(int i=1;i<=n;i++)
pre[i]=i; //用这种方法老是忘记这一步
int cnt = 0,ans = 0;
for(int i=1;i<n;i++)
{
cin>>a>>c;
a1 = a-'A'+1;
while(c--)
{
cin>>b>>d;
b1 = b-'A'+1;
p[cnt].x = a1;
p[cnt].y = b1;
p[cnt++].w = d;
}
}
sort(p,p+cnt,cmp);
for(int i=0;i<cnt;i++)
{
if(find(p[i].x) != find(p[i].y))
{
join(p[i].x,p[i].y);
ans+=p[i].w;
}
}
cout<<ans<<endl;
}
return 0;
}
上一篇: Python 发邮件报错 server_hostname cannot be an empty string or start with a leading dot.
下一篇: 最短路之dijkstra算法
推荐阅读
-
poj 2689Prime Distance(区间素数)埃氏筛法
-
JS使用Prim算法和Kruskal算法实现最小生成树
-
POJ3252Round Numbers(数位dp)
-
kuangbin专题专题四 Frogger POJ - 2253
-
数据结构(C实现)------- 最小生成树之Kruskal算法
-
python最小生成树kruskal与prim算法详解
-
kuangbin专题 专题一 简单搜索 棋盘问题 POJ - 1321
-
kuangbin专题 专题一 简单搜索 Prime Path POJ - 3126
-
POJ:1017-Packets(贪心+模拟,神烦)
-
poj1637 Sightseeing tour(混合图欧拉回路)