PAT A1107. Social Clusters (30)
- Social Clusters (30)
时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] … hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int N=1010;
int father[N];
int isRoot[N]={0};
int course[N]={0};
int findFather(int x){
int a=x;
while(x!=father[x]){
x=father[x];
}
//路径压缩
while(a!=father[a]){
int z=a;
a=father[a];
father[z]=x;
}
return x;
}
void Union(int a,int b){//让a所在群的所有人 称呼 b所在群的大哥 为 大哥
int faA=findFather(a);
int faB=findFather(b);
if(faA!=faB){
father[faA]=faB;
}
}
void init(int n){
for(int i=1;i<=n;i++){
father[i]=i;
isRoot[i]=false;
}
}
bool cmp(int a,int b){
return a>b;
}
int main(){
int n,k,h;
scanf("%d",&n);
init(n);//初始化每个人的大哥是自己
for(int i=1;i<=n;i++){//对每个人
scanf("%d:",&k);
for(int j=0;j<k;j++){
scanf("%d",&h);
if(course[h]==0)
course[h]=i;//兴趣群h的大哥是第一个加入的人
Union(i,findFather(course[h]));//因为i在兴趣群h中 那么 让i所在群所有人 称呼 兴趣群h的大哥的大哥 为大哥
}
}
for(int i=1;i<=n;i++){
isRoot[findFather(i)]++;//对每个人 寻找其大哥 大哥x被叫了几次就表示有isRoot[x]个小弟
}
int ans=0;
for(int i=1;i<=n;i++){
if(isRoot[i]!=0){
ans++;
}
}
printf("%d\n",ans);
sort(isRoot+1,isRoot+n+1,cmp);
for(int i=1;i<=ans;i++){
printf("%d",isRoot[i]);
if(i<ans)printf(" ");
}
return 0;
}
推荐阅读
-
PTA甲级 1107 Social Clusters (30分)
-
1107 Social Clusters (30分)/并查集
-
并查集练习 1107 Social Clusters (30分)
-
|并查集 与谁合并?|1107 Social Clusters (30分)
-
[C++] PAT 1107 Social Clusters (30分)
-
PAT-A 1107 Social Clusters(30 分)并查集入门
-
PAT.A1107 Social Clusters
-
PAT A1107. Social Clusters (30)
-
PAT A1107 Social Clusters (30分)
-
1107 Social Clusters (30分)[并查集]