1053 Path of Equal Weight
1053 Path of Equal Weight (30 分)
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
解析:用vector存树,按照weight从大到小排序,再dfs中记录路径。
#include<set>
#include<map>
#include<list>
#include<queue>
#include<deque>
#include<cmath>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>
using namespace std;
#define e exp(1)
#define p acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b) {
return b?gcd(b,a%b):a;
}
struct node{
int weight;
vector<int> children;
};
vector<node> tree;
vector<int> path;
int n,m,w;
bool cmp(int a,int b)
{
return tree[a].weight>tree[b].weight;
}
void dfs(int s,int sum)
{
if(sum>w)return ;
if(sum==w)
{
if(tree[s].children.size()!=0)return ;
printf("%d",tree[0].weight);
for(int i=0; i<path.size(); i++)
{
printf(" %d",path[i]);
}
printf("\n");
}
for(int i=0; i<tree[s].children.size(); i++)
{
int now=tree[s].children[i];
path.push_back(tree[now].weight);
dfs(now,sum+tree[now].weight);
path.pop_back();
}
}
int main()
{
scanf("%d%d%d",&n,&m,&w);
tree.resize(n);
for(int i=0; i<n; i++)
{
scanf("%d",&tree[i].weight);
}
int id,k;
for(int i=0; i<m; i++)
{
scanf("%d%d",&id,&k);
tree[id].children.resize(k);
for(int j=0; j<k; j++)
{
scanf("%d",&tree[id].children[j]);
}
sort(tree[id].children.begin(),tree[id].children.end(),cmp);
}
dfs(0,tree[0].weight);
return 0;
}
推荐阅读
-
PAT A1053:Path of Equal Weight
-
(pat)A1053 Path of Equal Weight
-
PAT A1053 Path of Equal Weight(30 分)
-
PAT A1053 Path of Equal Weight (30分)
-
PAT甲级——A1053 Path of Equal Weight【30】
-
PAT甲级——A1053 Path of Equal Weight
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30 分)
-
1053 Path of Equal Weight (30分)