PTA甲级 1063 Set Similarity (25分)-set的用法
文章目录
强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬
本文由参考于柳神博客写成
PS 今天也要加油鸭
题目原文
Given two sets of integers, the similarity of the sets is defined to be N**c/N**t×100%, where N**c is the number of distinct common numbers shared by the two sets, and N**t is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
生词如下:
distinct 明显的,有区分的.
similarity 相同的.
a pair of set numbers 一对集合数
query 疑问,询问.
题目大意:
就是给你N个集合
然后再给你N个集合数–就是两个数字,代表的是集合的序列.
问.这两个集合中有多少重复的数.算出重合率.
并输出
思路如下:
用set来保存.因为set有自动的去重功能.
把两个集合的长度加起来.算出第三个集合的长度在减去任意一个集合就是重合的.
然后再除一下.就OK了.
而且调用几个函数的事情.
如果这样做的话.恭喜你.测试点五是过不去的.
太浪费时间了
我们改进一下.
把短的集合里面的数在长集合里一个一个找出来.
代码如下:
这就是我能想到的最短的代码了.格式还改的不是很好看.阅读起来可能优点困难
#include<iostream>
#include<set>
using namespace std;
int main(void) {
int N=0,M=0,cnt=0,K = 0;;
string t;
scanf("%d", &N);
set<string> setarray[55];
//这个就是全部的录入函数,把所有的set都读取完毕.
for (int i = 0; i < N; ++i) {
scanf("%d", &M);
for (int j = 0; j < M; ++j) {
cin >> t;
setarray[i].insert(t);
}
}
set<string> sum;
scanf("%d", &K);
for (int i = 0; i < K; ++i) {
int begin=0, end=0;
scanf("%d%d", &begin, &end);
float Add = setarray[begin-1].size() + setarray[end-1].size();
int max = end - 1,min = begin - 1;
if (setarray[begin - 1].size() > setarray[end - 1].size()) {
min = end - 1;
max= begin - 1;
}
for (auto j : setarray[min]) {
if (setarray[max].find(j) != setarray[max].end()) {
cnt++;
}
}
printf("%.1f%%", ((float)cnt*100) /((float)(Add-cnt)));
if (i != K - 1) printf("\n");
sum.clear(); cnt = 0; //重新的清0代码
}
return 0;
}
柳神的思路:
分析:因为给出的集合里面含有重复的元素,而计算nc和nt不需要考虑两个集合里面是否分别有重复的元素,所以可以直接使用set存储每一个集合,然后把set放进一个数组里面存储。当需要计算集合a和集合b的相似度nc和nt的时候,遍历集合a中的每一个元素,寻找集合b中是否有该元素,如果有,说明是两个人公共的集合元素,则nc++,否则nt++(nt的初值为b集合里面本有的元素)
柳神的代码:
#include <cstdio>
#include <vector>
#include <set>
using namespace std;
int main() {
int n, m, k, temp, a, b;
scanf("%d", &n);
vector<set<int>> v(n);
for (int i = 0; i < n; i++) {
scanf("%d", &m);
set<int> s;
for (int j = 0; j < m; j++) {
scanf("%d", &temp);
s.insert(temp);
}
v[i] = s;
}
scanf("%d", &k);
for (int i = 0; i < k; i++) {
scanf("%d %d", &a, &b);
int nc = 0, nt = v[b - 1].size(); //一开始就是b的size对.
for (auto it = v[a - 1].begin(); it != v[a - 1].end(); it++) {
if (v[b - 1].find(*it) == v[b - 1].end())
nt++;
else
nc++;
}
double ans = (double)nc / nt * 100;
printf("%.1f%%\n", ans);
}
return 0;
}
如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗
相信我,你也能变成光.
如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.