欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Revenge of Segment Tree(思维)

程序员文章站 2022-06-07 21:44:52
...
 

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1796    Accepted Submission(s): 666


 

Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

 

 

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000

 

 

Output

For each test case, output the answer mod 1 000 000 007.

 

 

Sample Input

 

2 1 2 3 1 2 3

 

 

Sample Output

 
2 20

Hint

For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20. Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded. And one more little helpful hint, be careful about the overflow of int.

题意 : 求所有区间的和 .

题解: 对于当前第i 个数 ,我们只需要计算出一共在多少个子区间中出现a[i] , 再用  Revenge of Segment Tree(思维)  C(a[i]) 表示a[i] 在所有子区间的出现次数. 答案是C(a[i]) =   i*(n-i+1), i代表第i个数前面有多少个数,包括它自己,(n-i+1)代表第i个数后面有多少个数,包括它自己,然后相乘,代表前面的标号和后边的标号两两配对 .

参考 : https://blog.csdn.net/sr_19930829/article/details/40707173

如图:

Revenge of Segment Tree(思维)

 

#include <iostream>
#include <cstdio>
using namespace std ;
typedef long long LL ;
const LL mod = 1000000007 ;
int main(){
	int T  ;
	cin >>T ;
	while(T--){
		LL n  ;
		LL x  ;
		LL ans = 0 ;
		scanf("%I64d",&n);
		for(int i = 1 ; i<=n ;i++ ){
			scanf("%I64d",&x);
			ans = (ans +i*(n-i+1)%mod*x%mod)%mod ;
		}
		printf("%I64d\n",ans);
		
	}
	
	return 0 ;
}