欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【HDU】How Many Tables (并查集模板题)

程序员文章站 2022-05-29 08:17:16
...

题目传送门

题目描述:

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5
5 1
2 5

Sample Output

2
4

很有意思的并查集~
看到一篇很有意思的博客,写的很好,在这里贴一下 (戳这里

借助这道题说一下并查集的原理,俗话说,朋友的朋友即是朋友,所以我们在聚会时,为了减少桌子的用量,我们规定有这个么关系的一群人就可以坐在一张桌子,而若两个同学不认识,他们也没有互相认识的人,这样他们就不可以坐一桌,为了确定他们之间能不能做到一张桌子上,我们需要一个数组pre来标记我们每个人最好的朋友是谁,我们首先询问我们的好朋友认识某人,再通过询问朋友的好朋友达到查询的目的。

关于路径压缩算法,因为最后的树形结构查找效率非常低下(举个极端的栗子:比如说是一字蛇形阵),所以我们要把每个人的最后的祖先标记出来,那么我们的路径压缩算法的思想就如下图所示:
【HDU】How Many Tables (并查集模板题)
奉上代码:

#include<bits/stdc++.h>
#define N 10100
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e6+10;
int pre[maxn];
int unionserch(int root)
{
    int son,temp;
    son=root;
    while(root!=pre[root])//找祖先
    {
        root=pre[root];
    }
    while(son!=root)//路径压缩
    {
        temp=pre[son];
        pre[son]=root;
        son=temp;
    }
    return root;
}
int main()
{
    ios::sync_with_stdio(false);
    int n,m,t,x,y;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        pre[i]=i;
        for(int i=1;i<=m;i++)
        {
            cin>>x>>y;
            int bx=unionserch(x);
            int by=unionserch(y);
            if(bx!=by)
            pre[bx]=by;
        }
            int tol=0;
            for(int i=1;i<=n;i++)
            {
                if(pre[i]==i)
                   tol++;
            }
           cout<<tol<<endl;
    }
}

写的有点粗糙,先贴出来吧,有时间再改QWQ~
这是第五个,刚把带QAQ

相关标签: 打卡