Depth First Search 深度优先算法
典例 Lake Counting
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
本题是深度优先算法DFS的典型例题
所谓深度优先算法,就是从最初状态开始,把每一种情况都按一定顺序遍历(不一定遍历完)在寻找到想要的结果时便可以结束搜索。
这个题 我们可以使用DFS,用For循环遍历field数组,找到W便开始调用DFS函数,每调用一次就计数变量加一,这样可以记录水坑的个数。
具体的DFS函数的定义:我们进入DFS后,先把field[x][y]置为'.',然后定义八个方向变量,即利用两个for循环,在第二个for循环中,我们进行if判断(不越界+有‘W’) 满足便继续递归调用DFS,直至完成函数完整的一次调用。
谈到DFS,我觉得这与递归联系非常的紧密,或者说DFS的实现靠的就是递归函数。
AC:
#include<iostream>
using namespace std;
#include<bits/stdc++.h>
char field[101][101];
int M,N,CS=0;
int main()
{
void dfs(int,int);
cin>>N>>M;
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
cin>>field[i][j];
}
}
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
if(field[i][j]=='W') {dfs(i,j);CS++;}
}
}
cout<<"一共有"<<CS<<"个水坑啊!";
return 0;
}
void dfs(int x,int y)
{
field[x][y]='.';
for(int dy=-1;dy<=1;dy++)
{
for(int dx=-1;dx<=1;dx++)
{
int x1=x+dx;
int y1=y+dy;
if(x1>=0&&x1<N&&y1<M&&y1>=0&&field[x1][y1]=='W')
{
dfs(x1,y1);
}
}
}
}