JZOJ-senior-5935. 【NOIP2018模拟10.29】小凯学数学
程序员文章站
2022-05-21 12:11:25
...
Time Limits: 1000 ms Memory Limits: 262144 KB
Description
由于小凯上次在找零问题上的疑惑,给大家在考场上带来了很大的麻烦,他决心好好学习数学
本次他挑选了位运算专题进行研究 他发明了一种叫做“小凯运算”的运算符:
a$b =( (a&b) + (a|b) )>>1
他为了练习,写了n个数在黑板上(记为a[i]) 并对任意相邻两个数进行“小凯运算”,把两数擦去,把结果留下 这样操作n-1次之后就只剩了1个数,求这个数可能是什么?
将答案从小到大顺序输出
Input
4
1 4 3 2
Output
1 2
Sample Input
4
1 4 3 2
Sample Output
1 2
Data Constraint
30% n<=10 0<=a[i]<=7
70% n<=150 0<=a[i]<=3
100% n<=150 0<=a[i]<=7
Solution
DP
Code
#include<algorithm>
#include<cstdio>
#define fo(i,a,b) for(int i=a;i<=b;++i)
#define fd(i,a,b) for(int i=a;i>=b;--i)
using namespace std;
const int N=155,M=10;
int n,a[N],f[N][N][M];
int get(int a,int b)
{
return ((a&b)+(a|b))>>1;
}
int main()
{
freopen("math.in","r",stdin);
freopen("math.out","w",stdout);
scanf("%d",&n);
fo(i,1,n) scanf("%d",&a[i]),f[i][i][a[i]]=1;
fo(len,1,n-1)
fo(l,1,n-len)
{
int r=l+len;
fo(k,l,r-1)
fo(i,0,7) if(f[l][k][i])
fo(j,0,7) if(f[k+1][r][j])
f[l][r][get(i,j)]=1;
}
fo(i,0,M) if(f[1][n][i]) printf("%d ",i);
}
上一篇: SSLOJ 1231.Gift