迷宫问题 POJ - 3984
程序员文章站
2022-05-20 22:52:33
...
迷宫问题 POJ - 3984
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
using namespace std;
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
bool vis[5][5];
int a[5][5];
bool judge(int x,int y)
{
if(x<0||y<0||x>4||y>4)
return true;
if(a[x][y]==1)
return true;
if(vis[x][y])
return true;
return false;
}
struct node{
int x;
int y;
int s;
short l[105];
};
node bfs()
{
queue<node>q;
node cur,next;
cur.x=0;
cur.y=0;
cur.s=0;
q.push(cur);
vis[cur.x][cur.y]=true;
while (!q.empty())
{
cur=q.front();
q.pop();
if(cur.x==4&&cur.y==4)
{
return cur;
}
vis[cur.x][cur.y]=true;
int nx,ny;
for(int i=0;i<4;i++)
{
nx=cur.x+dx[i];
ny=cur.y+dy[i];
if(judge(nx,ny))
{
continue;
}
next=cur;
next.x=nx;
next.y=ny;
next.s=cur.s+1;
next.l[cur.s]=i;
q.push(next);
}
}
}
int main()
{
int i,j;
for(i=0;i<5;i++)
{
for(j=0;j<5;j++)
{
cin>>a[i][j];
}
}
node ans=bfs();
int x=0,y=0;
for(i=0;i<=ans.s;i++)
{
printf("(%d, %d)\n",x,y);
x+=dx[ans.l[i]];
y+=dy[ans.l[i]];
}
return 0;
}
上一篇: POJ 3984 迷宫问题 广搜迷宫解法
下一篇: 迷宫问题 POJ - 3984