欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ - 3984 迷宫问题(深搜+记录)

程序员文章站 2022-05-20 21:35:22
...

题目链接:http://poj.org/problem?id=3984点击打开链接

迷宫问题
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23348   Accepted: 13614

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source



用一个动态数组记录深搜过程 到终点就用另一个记录答案 比较取最短路就行

逗号旁边有个空格

#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int dir[4][2]={1,0,-1,0,0,1,0,-1};
struct xjy
{
    int x;
    int y;
};
vector < xjy >ans;
vector < xjy >midmid;
vector < xjy >::iterator it;
int mmap[10][10];
void dfs(int x,int y)
{
    if(x==5&&y==5)
    {
        if(ans.size()>midmid.size()||ans.size()==0)
            ans=midmid;
        return ;
    }
    for(int i=0;i<4;i++)
    {
        xjy mid;
        mid.x=x+dir[i][0];
        mid.y=y+dir[i][1];
        if(!mmap[mid.x][mid.y])
        {
            mmap[x+dir[i][0]][y+dir[i][1]]=1;
            midmid.push_back(mid);
            dfs(mid.x,mid.y);
            mmap[x+dir[i][0]][y+dir[i][1]]=0;
            midmid.erase(midmid.end()-1);
        }
    }
}
int main()
{
    for(int i=0;i<=9;i++)
        for(int j=0;j<=9;j++)
            mmap[i][j]=1;
    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++)
        {
            scanf("%d",&mmap[i][j]);
        }
    dfs(1,1);
    cout << "(0, 0)" << endl;
    for(it=ans.begin();it!=ans.end();it++)
        cout << "(" << (*it).x-1 << ", " << (*it).y-1 << ")" << endl;
}