欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT 1130.Infix Expression(25 分)中缀表达式

程序员文章站 2022-05-20 13:46:01
...

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

PAT 1130.Infix Expression(25 分)中缀表达式 PAT 1130.Infix Expression(25 分)中缀表达式
Figure 1 Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

先想办法得到root的值,将输入的点所指左右结点设为visit = true,最终visit=false的必是root

中缀表达式输出  是个算术表达式 右子树必是存在的 ,(...)* 不存在;左子树可能不存在 +(...)

中序遍历 左 根 右  左右加括号

#include <iostream>
#include <vector>
using namespace std;
struct node {
    string data;
    int left, right;
};
vector<node> v;
int n, root = 1;
string dfs(int index) {
    if (index == -1) return "";
    if (v[index].right != -1) {
        v[index].data = dfs(v[index].left) + v[index].data + dfs(v[index].right);
        if (index != root) v[index].data = '(' + v[index].data + ')';
    }
    return v[index].data;
}
int main() {
    cin >> n;
    v.resize(n + 1);
    vector<bool> visit(n + 1, false);
    for (int i = 1; i <= n; i++) {
        cin >> v[i].data >> v[i].left >> v[i].right;
        if (v[i].left != -1) visit[v[i].left] = true;
        if (v[i].right != -1) visit[v[i].right] = true;
    }
    while (visit[root] == true) root++;
    cout << dfs(root) << endl;
    return 0;
}

 

相关标签: dfs 中序遍历