hdu 2025 查找最大元素
程序员文章站
2022-05-13 16:01:13
...
查找最大元素
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80442 Accepted Submission(s): 42207
Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
Sample Input
abcdefgfedcba
xxxxx
Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)
题目分析
我们可以先找出最大的字母记录他的位置,再进行循环逐一打出字只需价格特判如果是最大字母后面须打上(max);
代码
#include<stdio.h>
#include<string.h>
int main()
{
char a[100];
while(scanf("%s",a)!=EOF)
{
getchar();
int i;
char arena='0';
for(i=0;a[i]!='\0';i++)
if(a[i]>=arena)
arena=a[i];//寻找并记录
for(i=0;a[i]!='\0';i++)
{
printf("%c",a[i]);//直接打印
if(a[i]==arena) printf("(max)");//若最大则打印(max)
}
printf("\n");
}
return 0;
}