欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

简单计算器

程序员文章站 2022-03-07 17:04:49
...

总Time Limit: 1000ms Memory Limit: 65536kB
Description
一个最简单的计算器,支持+, -, *, / 四种运算。仅需考虑输入输出为整数的情况,数据和运算结果不会超过int表示的范围。

Input
输入只有一行,共有三个参数,其中第1、2个参数为整数,第3个参数为操作符(+,-,*,/)。
Output
输出只有一行,一个整数,为运算结果。然而:

  1. 如果出现除数为0的情况,则输出:Divided by zero!
  2. 如果出现无效的操作符(即不为 +, -, *, / 之一),则输出:Invalid operator!
    Sample Input
    1 2 +
    Sample Output
    3
    Hint
    可以考虑使用if和switch结构。
#include<iostream>
#include<cstdio>
using namespace std;
int main(){
	int a,b;
	char c;
	cin>>a>>b>>c;
	switch(c){
		case'+': printf("%d\n",a+b);break;
		case'-': printf("%d\n",a-b);break;
		case'*': printf("%d\n",a*b);break;
		case'/': {
			if(!b) {
				printf("Divided by zero!\n");
				return 0;
			}
			else {
				printf("%d\n",a/b);
				break;
			}
		} 
		default: printf("Invalid operator!");
	}
	return 0;
}
相关标签: c