欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ3320Jessica's Reading Problem解题报告---尺取法

程序员文章站 2022-05-09 08:56:18
...

                               Jessica's Reading Problem

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

题意:一本书有P页,每一页一个知识点,不同页存在重复知识点,求覆盖所有的知识点的最少连续页数。

尺取法思路:

 1.初始化左右端点

2.不断扩大右端点,直到满足条件

3.第二步无法满足条件则直接终止,否则更新结果

4.左端点扩大1,继续第二步

#include <iostream>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <vector>
#include <algorithm>
#include <map>
#include <set>
#define Mod 1000000007
typedef long long ll;
using namespace std;
static const int MAX_N = 1000005;
int arr[MAX_N];
map<int, int>mps;
int main() {
	int n;
	while (scanf("%d", &n) != EOF) {
		mps.clear();
		for (int i = 0; i < n; i++) {
			scanf("%d", &arr[i]);
			mps[arr[i]]++;
		}
		int len = mps.size();
		mps.clear();
		int right = 0, left = 0, cnt = 0, res = MAX_N;
		while (1) {
			while (right < n && cnt < len) {
				if (mps[arr[right++]]++ == 0) {
					cnt++;
				}
			}
			if (cnt < len) break;
			res = min(res, right - left);
			if (--mps[arr[left++]] == 0) {
				cnt--;
			}
		}
		printf("%d\n", res);
	}
}

 

相关标签: POJ