Drying 二分查找
Drying
It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).
Output a single integer — the minimal possible number of minutes required to dry all clothes.
sample input #1 3 2 3 9 5 sample input #2 3 2 3 6 5Sample Output
sample output #1 3 sample output #2 2
还有洗衣机功率要是是1 要防止除以0 再结合实际意义
具体请看代码
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
long long n,d;
const int MAX_N = 100005;
int clo[MAX_N];
int check(long long p){
long long num = 0;
//dbg(p);
for(int i = 1;i<=n;++i){
if(p>=clo[i]) continue;
else {
//dbg((((clo[i]-p-1)/(d-1))+1));
num+=(((clo[i]-p-1)/(d-1))+1);
//dbg(num);
}
}
// dbg(p);
if(num<=p) return 1;
else return 0;
}
int main(){
int maxx;
while(scanf("%lld",&n)==1){
maxx = -1;
for(int i= 1;i<=n;++i){
scanf("%d",&clo[i]);
if(maxx<clo[i]) maxx=clo[i];
}
scanf("%lld",&d);
if(d==1) printf("%d\n",maxx);
else {
int l=0,r=maxx;
while(l<=r){
//dbg(l);
//dbg(r);
int mid=(l+r)>>1;
if(check(mid)) r = mid-1;
else l = mid+1;
}
printf("%d\n",l);
}
}
return 0;
}