欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ2309 BST【二叉搜索树】

程序员文章站 2022-04-25 07:49:52
...

BST

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10895   Accepted: 6656

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

POJ2309 BST【二叉搜索树】

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

POJ Monthly,Minkerui

 

问题链接POJ2309 BST

问题描述

  对于二叉搜索树,给出一个节点,求该节点子树的最小和最大编号。

问题分析

  标准的BST题,先占个位置。

程序说明

  函数lowbit()在树状数组中是重要的函数。

参考链接:(略)

题记:(略)

 

AC的C++语言程序如下:

/* POJ2309 BST */

#include <iostream>

using namespace std;

int lowbit(int x) { return x & -x; }

int main()
{
    ios::sync_with_stdio(false);
    int n, x;
    cin >> n;
    while(n--) {
        cin >> x;
        cout << x - lowbit(x) + 1 << ' ' << x + lowbit(x) - 1 << endl;
    }

    return 0;
}

 

 

 

 

相关标签: POJ2309 BST