欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

贪心--hdu-1052- Tian Ji -- The Horse Racing

程序员文章站 2022-03-05 15:21:18
...
 

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35544    Accepted Submission(s): 10693


 

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

贪心--hdu-1052- Tian Ji -- The Horse Racing

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

 

 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

Sample Input

 

3

92   83   71

95   87   74

 

2

20   20

20   20

 

2

20    19

22    18

 

0

Sample Output

200 
0 
0

Source

2004 Asia Regional Shanghai

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1053 1789 2187 2570 2111 

 

题意:给出自己马的速度,对方马的速度,通过调整使得 自己马获胜的次数最多。

贪心--hdu-1052- Tian Ji -- The Horse Racing

题解:1>.己方快马和对方快马比,快-->up++(up 指当前己方所赢次数),慢或等速,执行 2>

             2>.己方慢马和对方快马比,等速无操作,慢,执行 3>

             3>.up--

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1005],b[1005];

bool cmp(int x,int y){
	return x>y;
}
int main(){
	int n;
	while(scanf("%d",&n),n){
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		for(int i=0;i<n;i++){
			scanf("%d",&b[i]);
		}
		sort(a,a+n,cmp);
		sort(b,b+n,cmp);
		
		int up=0,lose=0,end1=n-1,end2=n-1,start1=0,start2=0;
		while(start1<=end1&&start2<=end2){
			if(a[start1]>b[start2]){
				up++;
				start1++;
				start2++;
			}
			else{
				while(a[end1]>b[end2]){
					end1--;
					end2--;
					up++;
				}
				if(end1>=start1){
					if(a[end1]<b[start2]){
						start2++;
						end1--;
						up--;
					}
					else{
						start2++;
						end1--;
					}
				}
			}
		}
		printf("%d\n",up*200);
	}
	return 0;
}

 

相关标签: 贪心