PTA-实验五-圆形体体积计算器
7-1 圆形体体积计算器 (20分)
本题要求实现一个常用圆形体体积的计算器。计算公式如下:
球体体积 V=
3
4
πr
3
,其中r是球体半径。
圆柱体体积 V=πr
2
h,其中r是底圆半径,h是高。
圆锥体体积 V=
3
1
πr
2
h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。
输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。
当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。
输入样例:
1
2
3
2.4 3
0
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
自己重做了一遍实验之后不知道在PTA哪里可以提交检查,PTA里那题规定是用C语言的。。。
不知道在最后加个endl可不可以咧,不加的话就不会分行
#include<iostream>
#include<iomanip>
#define PI 3.1415926535
using namespace std;
int main()
{
int n;
double r,h,V;
while(1)
{ cout<<"1-Ball"<<endl<<"2-Cylinder"<<endl<<"3-Cone"<<endl<<"other-Exit"<<endl<<"Please enter your command:";
cin>>n;
switch(n)
{
case 1:
cout<<"Please enter the radius:";
cin>>r;
V=4*PI*r*r*r/3;
cout<<setiosflags(ios::fixed)<<setprecision(2)<<V;
break;
case 2:
cout<<"Please enter the radius:";
cin>>r>>h;
V=PI*r*r*h;
cout<<setiosflags(ios::fixed)<<setprecision(2)<<V;
break;
case 3:
cout<<"Please enter the radius:";
cin>>r>>h;
V=PI*r*r*h/3;
cout<<setiosflags(ios::fixed)<<setprecision(2)<<V;
break;
default:return 0;
}
cout<<endl;
}
}
本文地址:https://blog.csdn.net/u011339832/article/details/110160827
上一篇: 解决IDEA配置tomcat启动报错问题
下一篇: 详解Python中的路径问题