欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  IT编程

航电2054 《A==B?》

程序员文章站 2022-04-14 08:41:57
A == B ?*Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 160757 Accepted Submission(s): 26406*Problem DescriptionGive you two numbers A and B, if A is equal to B, you should print "YES", or print...

A == B ?

*Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 160757 Accepted Submission(s): 26406
*

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO
//-std=c++11 -lwsock32
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#include<sstream>
#include<iterator>
using namespace std;
int main()
{
	std::ios::sync_with_stdio(false);
	
	string a,b;
	while(cin>>a>>b){
		//去除a前0 
		while(*a.begin() == '0') 
			a.erase(a.begin());
		//如果是小数 去掉后缀0 
		if(a.find(".") != a.npos)
		{
			while(*(a.end()-1) == '0') 
				a.erase(a.end()-1);
			if(*(a.end()-1) == '.')
				a.erase(a.end()-1);
		}
		//去除b前0 
		while(*b.begin() == '0') 
			b.erase(b.begin());
		//如果是小数 去掉后缀0 
		if(b.find(".") != b.npos)	
		{
			while(*(b.end()-1) == '0') 
				b.erase(b.end()-1);
			if(*(b.end()-1) == '.')
				b.erase(b.end()-1);
		}
			
		//去除负数的前导0
		if(*a.begin() == '-')
		{
			while(*(a.begin()+1) == '0') 
				a.erase(a.begin()+1);
		}
		if(*b.begin() == '-')
		{
			while(*(b.begin()+1) == '0') 
				b.erase(b.begin()+1); 
		}
		if(a=="-" || a=="") a="0";
		if(b=="-" || b=="") b="0";
//		cout<<"A="<<a<< "\t"<<"B="<<b<<endl;
		cout<<(a==b?"YES":"NO")<<endl;
	}
	return 0;
}

本文地址:https://blog.csdn.net/TAOTAO_JJ/article/details/109003731

相关标签: acm竞赛