欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

hdu 2084 数塔(递推)

程序员文章站 2022-04-13 20:40:59
...

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51592    Accepted Submission(s): 30390


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
hdu 2084 数塔(递推)
已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input

1573 88 1 0 2 7 4 44 5 2 6 5
 

Sample Output

30
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1087 1159 1069 2602 1058 

题意:从顶层到底层,求最大和

思路:递推,可以从顶层往下推,最后一层判断一下最大;也可以从底层往上推,顶层即是最大。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define IO ios::sync_with_stdio(false);cin.tie(0);
using namespace std;
int a[110][110];
int main()
{
	int n, m;
	cin >> n;
	while(n--){
		memset(a, 0, sizeof(a));
		cin >> m;
		for(int i = 1; i <= m; i++){
			for(int j = 1;j <= i; j++){
				cin >> a[i][j];
			} 
		}
		for(int i = m-1; i >= 1; i--){//从最后一层往上累计 
			for(int j = 1; j <= i; j++){
				a[i][j] += max(a[i+1][j], a[i+1][j+1]);
			}
		}
		cout << a[1][1] << endl;
	} 
	return 0;
} 

代码2:顺手又写了一个保存路径的,本来思路局限在边求和边存位置上了,其实不用,可以用当前最大和减去当前位置的数,即是路径中下一行的和。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define IO ios::sync_with_stdio(false);cin.tie(0);
using namespace std;
int a[110][110], b[110][110];
int main()
{
	int n, m;
	cin >> n;
	while(n--){
		memset(a, 0, sizeof(a));
		cin >> m;
		for(int i = 1; i <= m; i++){
			for(int j = 1;j <= i; j++){
				cin >> a[i][j];
				b[i][j] = a[i][j];
			} 
		}
		for(int i = m-1; i >= 1; i--){//从最后一层往上累计 
			for(int j = 1; j <= i; j++){
				a[i][j] += max(a[i+1][j], a[i+1][j+1]);
			}
		}
		cout << a[1][1] << endl;
		int tmp, loc=1;
		cout << b[1][1];
		for(int i = 2; i <= m; i++){
			tmp = a[i-1][loc]-b[i-1][loc]; 
			if(a[i][loc] == tmp){
				cout << " " << b[i][loc]; 
			}
			else if(a[i][loc+1] == tmp){
				cout << " " << b[i][loc+1];
				loc++;
			}
		}
	} 
	return 0;
} 

相关标签: 递推