欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

杭电2923(Floyd最短路+给符号判断边的方向+map对输入字符串处理)

程序员文章站 2022-04-06 20:20:16
...

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company’s garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company’s garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company’s garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company’s garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company’s garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:

A -v -> B
A <-v - B
A <-v -> B

A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , “the arrow”, and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.
杭电2923(Floyd最短路+给符号判断边的方向+map对输入字符串处理)

Output

For each test case, print the total distance traveled using the following format:

k . V

Where k is test case number (starting at 1,) is a space, and V is the result.

Sample Input

4 2 5
NewTroy Midvale Metrodale
NewTroy <-20-> Midvale
Midvale –50-> Bakerline
NewTroy <-5– Bakerline
Metrodale <-30-> NewTroy
Metrodale –5-> Bakerline
0 0 0

Sample Output

1.80(1.和80之间有空格)

思路:

Floyd算法,从某点出发,一次只能拖一辆车,求拖走所有车所需时间。
用map处理字符串,要多加注意。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

#define INF 0xfffffff
#define maxn 1010
int n,c,r;//n个位置c辆破车r条道 
int path[maxn][maxn];//两点间距离 
char carloc[maxn][maxn];//车所在城市 
char s[maxn],ch,t[maxn],cha;//输入的城市,</-,输入的城市,>/-
int icase=0,len;//cases,路的长度 
map<string,int>city;

void floyd()
{
    for(int k=0;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            if(path[i][k]!=INF)
            {
                for(int j=0;j<=n;j++)
                {
                    if(path[i][j]>path[i][k]+path[k][j])
                    {
                        path[i][j]=path[i][k]+path[k][j];
                    }
                }
            }
        }
    }
}

int main()
{
    int cnt,start,output;//城市编号,起点公司,输出结果 
    while(scanf("%d%d%d",&n,&c,&r)!=EOF)
    {
        if(n==0&&c==0&&r==0) break;
        city.clear();
        //init
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                if(i==j) path[i][j]=0;
                else path[i][j]=INF;
            }
        }
        //input
        for(int i=0;i<=c;i++)
        {
            cin>>carloc[i];
        }

        //破车所在城市编号 
        cnt=1;
        //input破车 
        for(int i=0;i<r;i++)
        {
            scanf("%s %c-%d-%c %s",s,&ch,&len,&cha,t);
            if(!city[s]) city[s]=cnt++;
            if(!city[t]) city[t]=cnt++;
            if(ch=='<'&&len<path[city[t]][city[s]]) path[city[t]][city[s]]=len;
            if(cha=='>'&&len<path[city[s]][city[t]]) path[city[s]][city[t]] =len;
        }
        floyd();
        //起始点公司start 
        start=city[carloc[0]];
        output=0; 
        for(int i=1;i<=c;i++)
        {
            //输出为拖走每一辆车来回的路径和 
            output+=path[start][city[carloc[i]]]+path[city[carloc[i]]][start];
        }
        cout<<++icase<<". "<<output<<endl;
    }
    return 0;
}
相关标签: ACM 最短路径