HDU 6159 cable cable cable (规律水题)
题目链接:
http://acm.hdu.edu.cn/showproblem.php?pid=6195
Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time.
Now you have MM display screens and KK different signal sources(K≤M≤232−1K≤M≤232−1). Select KK display screens from MM display screens, how many cables are needed at least so that **any** KK display screens you select can show exactly KK different colors.
Input
Multiple cases (no more than 100100), for each test case:
there is one line contains two integers MM and KK.Output
Output the minimum number of cables NN.
Sample Input
3 2 20 15
Sample Output
4 90
题意:
每个信号源都有不同的颜色,有M个显示屏和K个信号源,求最少的连线使得k个显示屏有k种颜色
思路:
先取k个显示屏各连一个信号源。剩下的(m-k)个显示屏必然每个都连k个信号源才能满足条件。
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
ll n,k;
while(~scanf("%lld%lld",&n,&k)){
printf("%lld\n",(n-k+1)*k);
}
return 0;
}