欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  IT编程

HDU1398 Square Coins(生成函数)

程序员文章站 2022-04-02 23:40:00
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13791 Accepted Submission(s): 9493 Problem Descri ......

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13791    Accepted Submission(s): 9493


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

 

Sample Input
2 10 30 0
 

 

Sample Output
1 4 27
 

 

Source
 

 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:       
 
题目大意:
仅用价值为$i^2$的硬币,拼出$N$的方案数
 
sol:
对于每个硬币都构造生成函数$ax^i$表示价值为$i$时的方案数
全都乘起来就好
 
#include<cstdio>
#include<cstring>
#include<algorithm>
const int MAXN = 301;
inline int read() { 
    char c = getchar(); int x = 0, f = 1;
    while(c < '0' || c > '9') {if(c == '-') f = -1; c = getchar();}
    while(c >= '0' && c <= '9') x = x * 10 + c - '0', c = getchar();
    return x * f;
}
int cur[MAXN], nxt[MAXN], now[MAXN];
int main() {
    int N;
    for(int i = 1; i <= 18; i++)
        now[i] = i * i;
    while(scanf("%d", &N) && N) {
        memset(cur, 0, sizeof(cur));
        for(int i = 0; i <= N; i++) cur[i] = 1;
        for(int i = 2; now[i] <= N; i++) {
            for(int j = 0; j <= N; j++) 
                for(int k = 0; j + now[i] * k <= N; k++) 
                    nxt[j + k * now[i]] += cur[j];
            memcpy(cur, nxt, sizeof(nxt));
            memset(nxt, 0, sizeof(nxt));
        }
        printf("%d\n", cur[N]);
    }
    return 0;
}