欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

133 - The Dole Queue 算法竞赛第四章

程序员文章站 2022-04-02 21:29:45
...

Time limit: 3.000 seconds

Problem Description

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter- clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).
Note: The symbol ⊔ in the Sample Output below represents a space.

sample input

10 4 3
0 0 0

sample output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7


#include<stdio.h>
#define maxn 25
int n,k,m,a[maxn];
int go(int p,int d,int t){
	while(t--){
		do{
			p=(p+d+n-1)%n+1;
		}while(a[p]==0);
	}
	return p;
}
int main(){
	while(scanf("%d%d%d",&n,&k,&m)&&n){
		for( int i=1; i<=n; i++ )a[i]=i;
		int p1=0,p2=n+1,left=n;
		while(left){
			p1=go(p1,1,k);p2=go(p2,-1,m);
			printf("%3d",p1);left--;
			if(p1!=p2){
				printf("%3d",p2);left--;
			}
			if(left) printf(",");
			a[p1]=a[p2]=0;
		}
		printf("\n");
	}
	return 0;
}
相关标签: 第四章