欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Squares

程序员文章站 2022-04-02 21:30:03
...

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.
Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output
For each test case, print on a line the number of squares one can form from the given stars.

Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0
Sample Output
1
6
1

已知: (x1,y1) (x2,y2)

则: x3=x1+(y1-y2) y3= y1-(x1-x2)

x4=x2+(y1-y2) y4= y2-(x1-x2)

x3=x1-(y1-y2) y3= y1+(x1-x2)

x4=x2-(y1-y2) y4= y2+(x1-x2)

代码一
#include <cmath>
#include <queue>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
 
typedef struct point
{
    int x;
    int y;
}PO;
 
bool cmp(PO x,PO y)
{
    if(x.x == y.x) return x.y < y.y;
    else return x.x < y.x;
}
 
void trans(PO i,PO j,PO &C,PO &D,int f)
{
    int tx = i.x - j.x;
    int ty = i.y - j.y;
    C.x = i.x + f * ty;
    C.y = i.y - f * tx;
    D.x = j.x + f * ty;
    D.y = j.y - f * tx;
}
 
bool find(PO P[],int n,PO C)
{
    int l,r;
    l = 0,r = n - 1;
    while(l <= r)
    {
        int mid = (l + r) / 2;
        if(P[mid].x == C.x)
        {
            if(P[mid].y == C.y) return true;
            if(P[mid].y > C.y)
            {
                r = mid - 1;
            }
            if(P[mid].y < C.y)
            {
                l = mid + 1;
            }
        }
        if(P[mid].x < C.x)
        {
            l = mid + 1;
        }
        if(P[mid].x > C.x)
        {
            r = mid - 1;
        }
    }
    return false;
}
 
int main()
{
    int n;
    while(scanf("%d",&n) && n)
    {
        PO P[1000];
        int ans = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%d%d",&P[i].x,&P[i].y);
        }
        sort(P,P + n,cmp);
        for(int i = 0;i < n;i++)
        {
            for(int j = i + 1;j < n;j++)
            {
                PO C,D;
                trans(P[i],P[j],C,D,1);
                if(find(P,n,C) && find(P,n,D)) ans++;
                trans(P[i],P[j],C,D,-1);
                if(find(P,n,C) && find(P,n,D)) ans++;
            }
        }
        printf("%d\n",ans / 4);
    }
}

代码二
#include <iostream>
#include <stdio.h>
#include <set>
#include <cmath>
#include <algorithm>
#define e 1e-9
using namespace std;
struct node
{
    double x;
    double y;
}p[1010];
bool judege(double x,double y,int n)
{
    int low=0,mid,high=n-1;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(fabs(p[mid].x-x)<e&&fabs(p[mid].y-y)<e)
            return 1;
        else if(p[mid].x-x>e||(fabs(p[mid].x-x)<e&&p[mid].y-y>e))
            high=mid-1;
        else
            low=mid+1;
    }
    return 0;
}
bool cmp(node a,node b)
{
    return(a.x<b.x||(a.x==b.x&&a.y<b.y));
}
int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)
            break;
        for(int i=0;i<n;i++)
        {
            scanf("%lf %lf",&p[i].x,&p[i].y);
        }
        sort(p,p+n,cmp);
        int ans=0;
        double xx,yy,x,y;
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
        {
            if(i==j)
                continue;
            xx=(p[i].x+p[j].x)/2;
            yy=(p[i].y+p[j].y)/2;
            x=p[i].x-xx;
            y=p[i].y-yy;
            if(judege(xx-y,yy+x,n)&&judege(xx+y,yy-x,n))
                ans++;
        }
        cout<<ans/2<<endl;
    }
    return 0;
}
相关标签: 正方形判断