欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Period

程序员文章站 2022-03-02 19:24:37
...

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

题解:kmp算法中 求得数组得简单运用;

 

代码:

#include <iostream>
#include <cstdio>
using namespace std;

int n;
char temp[1000050];
int fail[1000050];

void getFail(int n) {					//n表示短字符串的长度
    int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			int t=i-j;
			if(j && i%t==0)
			cout<<i<<" "<<i/t<<endl;
            fail[i] = j;
		}
		else j = fail[j];
	}
}

int main()
{
    int kase=1;
    while(cin>>n && n)
    {
        getchar();
        scanf("%s",temp);
        cout<<"Test case #"<<kase++<<endl;
        getFail(n);
        cout<<endl;
    }
    return 0;
}

 

上一篇: Period

下一篇: Period