Period
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
Source
Southeastern Europe 2004
程序
#include<cstdio>
using namespace std;
char s[1000005];
int a[1000005];
int l,ll,ans;
void get(int l){
int i=0 ,k=-1 ;
a[0]=-1 ;
while(i<l){
if(k==-1 || s[i]==s[k]){
i++;
k++;
a[i]=k ;
}
else k=a[k] ;
}
}
int main(){
while(scanf("%d",&l)&&l){
scanf("%s",s);
ans++;
get(l);
printf("Test case #%d\n",ans);
for(int i=2;i<=l;i++){
ll=i-a[i] ;
if(i%ll==0 && i/ll!=1)
printf("%d %d\n",i,i/ll);
}
printf("\n");
}
return 0;
}
下一篇: Period
推荐阅读
-
Java日期时间API系列9-----Jdk8中java.time包中的新的日期时间API类的Period和Duration的区别
-
SqlException:ConnectionTimeout Expired. The timeout period elapsed during the post-login phase
-
浅谈JDK8中的Duration Period和ChronoUnit
-
Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool
-
Java日期时间API系列9-----Jdk8中java.time包中的新的日期时间API类的Period和Duration的区别
-
【python数据分析(18)】Pandas中时间序列处理(4)pd.to_period()与pd.to_timestamp()数据之间转换以及时间序列索引及切片
-
SqlException:ConnectionTimeout Expired. The timeout period elapsed during the post-login phase
-
HDU - 1358 Period(KMP的next数组)
-
Period
-
Period