HDU - 1412 {A} + {B}
程序员文章站
2022-03-23 13:29:18
...
{A} + {B}
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31568 Accepted Submission(s): 12658
Problem Description
给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.
Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.
Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.
Sample Input
1 2
1
2 3
1 2
1
1 2
Sample Output
1 2 3
1 2
水题,我用的unique。
参考文章:https://www.cnblogs.com/wangkundentisy/p/9033782.html
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 10000 + 10;
int main()
{
int n, m;
while (cin >> n >> m)
{
int t;
vector<int>ans;
vector<int>::iterator new_end;
for (int i = 0; i < n; i++)
{
cin >> t;
ans.push_back(t);
}
for (int i = 0; i < m; i++)
{
cin >> t;
ans.push_back(t);
}
sort(ans.begin(), ans.end());
new_end=unique(ans.begin(), ans.end());//unique的返回值为去重之后,第一个重复数字的地址。
ans.erase(new_end, ans.end());//erase为删除new_end到ans.end()的值。
printf("%d", ans[0]);
for (int i = 1; i <ans.size() ; i++)
printf(" %d", ans[i]);
printf("\n");
}
return 0;
}
下一篇: php出现上传找不到临时文件错误怎么办