欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

poj3087 Shuffle'm Up(模拟)

程序员文章站 2022-03-23 10:51:24
...

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

poj3087 Shuffle'm Up(模拟)

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

题意:

给出字符串长度为n的s1,s2,然后给出字符串长度为2*n的字符串s12,先把s2的第一个给放入一个新串,然后放s1第一个,重复操作。然后把的到的新串与s12比较是否一样,不一样再把新串的上半段复制给s1,下半段复制给s2,求出操作次数。

放在搜索里,想了半天不知道怎么搜,模拟做的。

ac代码

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<map>
using namespace std;
char s1[201];
char s2[201];
char s12[401];
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        cas++;
        int n;
        int i,j,k;
        int step=0;
        map<string,bool>vis;
        scanf("%d",&n);
        scanf("%s",&s1);
        scanf("%s",&s2);
        scanf("%s",&s12);
        vis[s12]=true;
        while(1)
        {
            char s[401];
            int cnt=0;
            for(i=0;i<n;i++)
            {
                s[cnt++]=s2[i];
                s[cnt++]=s1[i];
            }
            s[cnt]='\0';//不加会wa
            step++;
            if(!strcmp(s,s12))//已经找到
            {
                printf("%d %d\n",cas,step);
                break;
            }
            else if(strcmp(s,s12)&&vis[s])//没找到且进去循环
            {
                printf("%d -1\n",cas);
                break;
            }
            vis[s]=true;//将该状态记录
            for(i=0;i<n;i++)//上半段复制给s1
                s1[i]=s[i];
                s1[i]='\0';//不加会wa
            for(j=0;i<2*n;j++,i++)//下半段复制给s2
                s2[j]=s[i];
                s2[i]='\0';//不加会wa
        }
    }
    return 0;
}