ALDS1_1_C-Prime Numbers
程序员文章站
2024-03-22 23:18:10
...
Prime Numbers
A prime number is a natural number which has exactly two distinct natural number divisors: 1 and itself. For example, the first four prime numbers are: 2, 3, 5 and 7.
Write a program which reads a list of N integers and prints the number of prime numbers in the list.
Input
The first line contains an integer N, the number of elements in the list.
N numbers are given in the following lines.
Output
Print the number of prime numbers in the given list.
Constraints
1 ≤ N ≤ 10000
2 ≤ an element of the list ≤ 108
Sample Input 1
5
2
3
4
5
6
Sample Output 1
3
Sample Input 2
11
7
8
9
10
11
12
13
14
15
16
17
Sample Output 2
4
#include<cstdio>
#include<iostream>
using namespace std;
bool ss(int x){
int i;
i = 2;
if(x == 1 || x == 0) return false;
while(i*i <= x && x%i != 0) i++;
return i*i >x ;
}
int main(){
int ans = 0,i,a;
int n;
cin>>n;
for(int i = 0;i < n;i++)
{
cin >> a;
ans += ss(a);
}
cout << ans << endl;
return 0;
}
推荐阅读