欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Compound Words UVA - 10391

程序员文章站 2024-03-22 18:51:40
...

You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn

思路:创建三个String容器,再将每个单词分割出左右两部分,遍历匹配,如果可以左右均可匹配得到,则是复合词,输出。

#include <iostream>
#include<algorithm>
#include <set>
#include<vector>
#include <map>
#include<queue>
#include<string>
using namespace std;
int main()
{
	ios::sync_with_stdio(false);//使得cin,cout不存入缓冲区
	set<string> words;
	string word, left, right;
	while (cin>>word)
	{
		words.insert(word);
	}
	for (const auto &s:words)
	{
		for (int i = 1; i < s.size(); i++)
		{
			left.assign(s, 0, i);//拷贝左半部分i个字符
			if (words.count(left))//是否存在字符与左半部分匹配
			{
				right.assign(s,i, s.size()-i);//拷贝右半部分
				if (words.count(right))//右半部分是否匹配
				{
					cout << s << endl; break;
				}
			}
		}
	}
	return 0;
}