欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

首先定义一个带参数的宏,使两个参数的值互换

程序员文章站 2024-03-22 11:20:52
...

Problem Description

首先定义一个带参数的宏,使两个参数的值互换。并写出程序,输入两个数作为使用宏时的实参,输出已交换后的两个值。
Input

要求输入数据之间,以空格隔开;
Output

输出数据之间,以英文逗号隔开,最后换行。
Sample Input

3 4
Sample Output

4,3
Hint

Source

#include<stdio.h>
#include<string.h>
#define swap(a,b) {int t=a;a=b;b=t;}
int main()
{
    int a,b;
    scanf("%d%d",&a,&b);
    swap(a,b);
    printf("%d,%d\n", a ,b);
    return 0;
}