【折半枚举】POJ - 2785 4 Values whose Sum is 0
4 Values whose Sum is 0 POJ - 2785
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6 -45 22 42 -16 -41 -27 56 30 -36 53 -37 77 -36 30 -75 -46 26 -38 -10 62 -32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=4005;
int a[maxn],b[maxn],c[maxn],d[maxn],ab[maxn*maxn],cd[maxn*maxn];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cd[i*n+j]=c[i]+d[j]; //得到所有c,d的和的可能
}
}
sort(cd,cd+n*n);
int res=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
int p=-(a[i]+b[j]); //要求a,b的和跟cd中有相加可等0的
res+=upper_bound(cd,cd+n*n,p)-lower_bound(cd,cd+n*n,p);
}
}
printf("%d\n",res);
}
return 0;
}
推荐阅读
-
POJ 2785 4 Values whose Sum is 0 折半枚举
-
【折半枚举】POJ - 2785 4 Values whose Sum is 0
-
POJ - 27854 Values whose Sum is 0 (折半枚举,)
-
【POJ 2785】【折半枚举】4 Values whose Sum is 0【暑期 No.6】
-
4 Values whose Sum is 0 POJ - 2785
-
4 Values whose Sum is 0
-
POJ 2785 4 Values whose Sum is 0
-
POJ 2785 4 Values whose Sum is 0(hash)
-
第四十二题 UVA1152 和为0的4个值 4 Values whose Sum is 0
-
POJ-2785 4 Values whose Sum is 0(二分+双指针)