【OJ.3325】顺序表应用2:多余元素删除之建表算法
顺序表应用2:多余元素删除之建表算法
Time Limit: 3 ms Memory Limit: 600 KiB
Problem Description
一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
2、本题的目标是熟悉在顺序表原表空间基础上建新表的算法,要在原顺序表空间的基础上完成完成删除,建表过程不得开辟新的表空间;
3、不得采用原表元素移位删除的方式。
Input
第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。
Output
输出有n行,为每个顺序表删除多余元素后的结果
Sample Input
4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3
Sample Output
6 9 8
5
9 8 7 6 5
1 2 3 4 5
Hint
Source
#include <stdio.h>
#include<stdlib.h>
typedef struct node
{
int data[10005];
int last;
}ST;
ST *creatdelete(ST *head)
{
int i, j;
scanf("%d",&head->data[0]);
for(i = 1;i < head->last;i++)
{
scanf("%d",&head->data[i]);
for(j = 0;j < i;j++)
{
if(head -> data[i] == head -> data[j])
{
i--;
head -> last = head ->last-1;
}
}
}
return head;
}
int main()
{
ST *head;
int n, i;
scanf("%d",&n);
while(n--)
{
head = (ST *)malloc(sizeof(ST));
scanf("%d",&head->last);
head = creatdelete(head);
for(i = 0;i < head -> last;i++)
{
printf("%d",head->data[i]);
if(i != head->last-1)printf(" ");
else printf("\n");
}
}
return 0;
}
【AC】
#include<stdio.h>
#include<stdlib.h>
typedef struct node
{
int data[10005];
int last;
}ST;
ST *creatdelete(ST *head)
{
int i, j;
scanf("%d", &head -> data[0]);
for(i = 1; i < head -> last; i++)
{
scanf("%d", &head -> data[i]);
for(j = 0; j < i; j++)
{
if(head -> data[i] == head -> data[j])
{
i--;
head -> last = head -> last - 1;
}
}
}
return head;
}
int main()
{
ST *head;
int n, i;
scanf("%d", &n);
while(n--)
{
head = (ST *)malloc(sizeof(ST));
scanf("%d", &head -> last);
head = creatdelete(head);
for(i = 0; i < head -> last; i++)
{
printf("%d", head->data[i]);
if(i != head -> last - 1) printf(" ");
else printf("\n");
}
}
return 0;
}
上一篇: SDUT OJ 顺序表应用2:多余元素删除之建表算法
下一篇: c数据结构线性表之顺序表基本操作