并查集 判环
小希的迷宫
Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Yes
Yes
No
Hint
题意
题解:
就是判断是不是一棵树 前提不能有环的存在
AC代码
#include<cstdio>
#include<cstring>
#include<stack>
#include <set>
#include <queue>
#include <vector>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9+7;
int vis[100005];
int par[100005];
int x,y;
int flag,edge;
void init(){
for (int i = 1;i <= 100005; ++i){
par[i] = i;
edge = 0;
flag = 0;
vis[i] = 0;
}
}
int fd(int x){
if (x == par[x]) return x;
return par[x]=fd(par[x]);
}
void ut(int x,int y){
if (x==y)
{
flag = 1; return ;
}
int tx = fd(x);
int ty = fd(y);
if (tx!=ty){
par[tx] = ty;
edge++;
}
else flag = 1;
}
int main()
{
int mx;
while (scanf("%d%d",&x,&y),x!=-1||y!=-1){
if (x==0&&y==0)
{
printf("Yes\n"); continue;
}
init();
vis[x] = 1;
vis[y] = 1;
ut(x,y);
mx = -1;
mx = max(mx,x);
mx = max(mx,y);
while (scanf("%d%d",&x,&y),x!=0||y!=0){
ut(x,y);
vis[x] = 1;
vis[y] = 1;
mx = max(mx,x);
mx = max(mx,y);
}
int v = 0;
for (int i = 1;i <= mx; ++i){
if (vis[i]) v++;
}
if (!flag&&edge+1==v) printf("Yes\n");
else printf("No\n");
}
return 0;
}
Ice_cream’s world I
Description
ice_cream’s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7
Sample Output
3
Hint
题意
题解:
判断分成区块的个数 其实是判断环
AC代码
#include<cstdio>
#include<cstring>
#include<stack>
#include <set>
#include <queue>
#include <vector>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9+7;
int par[1005];
int x,y;
int flag,cnt;
void init(){
for (int i = 0;i < 1005; ++i){
par[i] = i;
}
}
int fd(int x){
if (x == par[x]) return x;
return par[x]=fd(par[x]);
}
void ut(int x,int y){
int tx = fd(x);
int ty = fd(y);
if (tx!=ty){
par[tx] = ty;
}
else cnt++;
}
int main()
{
int n,m;
while (scanf("%d%d",&n,&m)!=EOF){
init();
cnt = 0;
int x,y;
for (int i = 0;i < m; ++i){
scanf("%d%d",&x,&y);
ut(x,y);
}
printf("%d\n",cnt);
}
return 0;
}
上一篇: python实现md5和sha1加密
下一篇: MD5和SHA1加密demo