欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1013 数素数 (20分) Java题解 PAT (Basic Level) Practice (中文)

程序员文章站 2024-03-19 08:55:34
...

1013 数素数 (20分)

原题链接:传送门

一、题目:

1013 数素数 (20分) Java题解 PAT (Basic Level) Practice (中文)

输入样例 1:
5 27
输出样例 1:
11 13 17 19 23 29 31 37 41 43
47 53 59 61 67 71 73 79 83 89
97 101 103


二、解析:

思路:

  首先他题目给了M和N的范围,就可以得到一共有多少个素数,所以创建一个数组把这10000个素数算好存起来。
  之后就直接将需要打印的位置在素数数组中找到打印就行,需要注意换行和空格问题。

AC代码:
import java.util.Scanner;

/**
 * 1013 数素数 (20分)
 * 
 * @author: ChangSheng 
 * @date:   2019年12月15日 下午2:57:03
 */
public class P1013_ac_素数 {
	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);
		int M = s.nextInt();
		int N = s.nextInt();
		// 1.将10000个素数存起来
		int[] primes = new int[10000];
		int index = 0;
		for (int i = 2; i < 1000000; i++) {
			if (index > 9999) break; // 素数刚刚存够一万个
			if (isPrime(i)) primes[index++] = i;
		}
		// 2.打印M到N位置的素数
		int nextLine = 0;
		for (int i = M-1; i < N; i++) {
			// 如果到第10个数字,那么打印后换行
			if (nextLine == 9) {
				System.out.println(primes[i]);
				nextLine = 0;
			} else {
				// 如果是最后一个数字,不加空格
				if (i == N-1) {
					System.out.print(primes[i]);
				} else {
					System.out.print(primes[i]+" ");
				}
				nextLine++;
			}
		}
		
	}
	/** 素数判断 */
	public static boolean isPrime(int num) {
		for (int i = 2; i <= Math.sqrt(num); i++) {
			if (num % i == 0) return false;
		}
		return true;
	}
}