欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Hangman Judge uva489

程序员文章站 2024-03-19 08:38:10
...

In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each
game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game
of hangman, and are given as follows:
1.
The contestant tries to solve to puzzle by guessing one letter at a time.
2.
Every time a guess is correct, all the characters in the word that match the guess will be “turned
over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will
be counted as “solved”.
3.
Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which
needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.


| |
| O
| /|\
| |
| / \
_|
| |__
|___|
4.
If the drawing of the hangman is completed before the contestant has successfully guessed all the
characters of the word, the contestant loses.
5.
If the contestant has guessed all the characters of the word before the drawing is complete, the
contestant wins the game.
6.
If the contestant does not guess enough letters to either win or lose, the contestant chickens out.
Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins,
loses, or fails to finish a game.
Input
Your program will be given a series of inputs regarding the status of a game. All input will be in lower
case. The first line of each section will contain a number to indicate which round of the game is being
played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made
by the contestant. A round number of ‘
-1
’ would indicate the end of all games (and input).
Output
The output of your program is to indicate which round of the game the contestant is currently playing
as well as the result of the game. There are three possible results:
You win.
You lose.
You chickened out.
Sample Input
1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1
Sample Output
Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.
题意:每组数据先输入一个n,代表第几组数据,第二行是一个要猜的字符串,第三行是你猜的字符串,如果猜对了一个字母,就说你把第一个字符串中所有与你猜对的相同的字母都猜对了。如果第一个字符串中的字母全被猜对了,输出you win.如果猜错的次数达到7次,输出You lose. 否则输出You chickened out.注意猜已经猜过的字母也算错,当第二行的字母没有完全猜完,但是上面的单词已经全部猜出也对。

思路:建立一个26个字母的数组记录字母是否被猜出。

代码:

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int dict[26];
int check(int a[])
{
    for(int i=0;i<26;i++)
    {
        if(a[i]!=0)
            return 0;
    }
    return 1;
}
int main()
{
    int n;
    char a[105],b[105];
    while(scanf("%d",&n)&&n!=-1)
    {
        cin>>a;
        cin>>b;
        memset(dict,0,sizeof(dict));
        int lena,lenb;
        lena=strlen(a);
        lenb=strlen(b);
        int ans=0;
        int flag=0;
        for(int i=0;i<lena;i++)
        {
            dict[a[i]-'a']++;
        }
        for(int i=0;i<lenb;i++)
        {
            if(dict[b[i]-'a']!=0)
            {
                dict[b[i]-'a']=0;
            }
            else
            {
                ans++;
            }
            if(check(dict)&&ans<7)   // 注意地方
            {
                flag=1;
            }

        }
        cout<<"Round "<<n<<endl;
        if(flag)
        {
            cout<<"You win."<<endl;
        }
        else if(ans<7&&check(dict))
        {
            cout<<"You win."<<endl;
        }
        else if(ans<7&&check(dict)==0)
        {
            cout<<"You chickened out."<<endl;
        }
        else if(ans>=7)
        {
            cout<<"You lose."<<endl;
        }
    }
    return 0;
}