【UVA】202 Repeating Decimals
题目链接:Repeating Decimals
题目:
The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
fraction decimal expansion repeating cycle cycle length 1/6 0.1(6) 6 1 5/7 0.(714285) 714285 6 1/250 0.004(0) 0 1 300/31 9.(677419354838709) 677419354838709 15 655/990 0.6(61) 61 2 Write a program that reads numerators and denominators of fractions and determines their repeating cycles.
For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).
Input
Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.
Output
For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins — it will begin within the first 50 places — and place ‘...)’ after the 50th digit.
Sample Input
76 25
5 43
1 397
Sample Output
76/25 = 3.04(0)
1 = number of digits in repeating cycle
5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle
1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle
分析:
本题是求循环小数的循环节及其长度。求循环小数,可通过手算思路来算,每次存好初始的余数,再乘10除以除数,得到商。每次的被除数,都是之前一次的余数乘10后,对除数取余。判断是否是循环小数,只需看当前余数(用作被除数)是否曾经出现过。另外,通过num记录小数位数。
结果输出时,通过判断a的值等于余数的值,判断出循环起点。另外注意长度>50输出“...”。
另外注意结果中每组还要额外加一个空行!刚开始没加就pe了。
代码:
#include <stdio.h>
#include <string.h>
int main()
{
int quo[3005],rem[3005],k[3005];//商和余数,及标志小数位
int a,b,num,i; //a被除数,b除数,num为小数位数
while (~scanf("%d%d",&a,&b))
{
printf("%d/%d = %d.",a,b,a/b);
memset(k,0,sizeof(k));
a %= b;
for (num=1; a&&!k[a];num++)
//被除数非0且同样的被除数之前未出现过
{
k[a] = num;
rem[num] = a;
quo[num] = (10*a) / b;
a = (10*a) % b;
//printf("\nnum=%d,rem=%d,quo=%d\n",num,rem[num],quo[num]);
}
for (i=1; i<num && i<=50; i++)
{
if (a && rem[i] == a)printf("(");//回到循环起点
printf("%d",quo[i]);
}
if (!a) printf("(0");
if (num > 50) printf("...");
printf(")\n");
if (a==0) printf(" 1 = number of digits in repeating cycle\n\n");
else printf(" %d = number of digits in repeating cycle\n\n",num-k[a]);
}
return 0;
}
上一篇: UVA 839 天平
下一篇: UVA-839