欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

UVA 712 (13.08.23)

程序员文章站 2024-03-18 23:47:52
...

S-Trees

A Strange Tree (S-tree) over the variable set UVA 712 (13.08.23)is a binary tree representing a Boolean function UVA 712 (13.08.23).Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree's nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, andso on. The sequence of the variables UVA 712 (13.08.23)is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0's and 1's on terminal nodes are sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables UVA 712 (13.08.23),then it is quite simple to find out what UVA 712 (13.08.23)is: start with the root. Now repeat the following: if the node you are at is labelled with a variablexi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

UVA 712 (13.08.23)

Figure 1: S-trees for the function UVA 712 (13.08.23)

On the picture, two S-trees representing the same Boolean function, UVA 712 (13.08.23),are shown. For the left tree, the variable ordering is x1, x2, x3, and for the right tree it isx3, x1, x2.

The values of the variables UVA 712 (13.08.23),are given as a Variable Values Assignment (VVA)

UVA 712 (13.08.23)

with UVA 712 (13.08.23).For instance, (x1 = 1, x2 = 1 x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value UVA 712 (13.08.23).The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computesUVA 712 (13.08.23)as described above.

Input

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n, UVA 712 (13.08.23),the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1xi2 ...xin. (There will be exactly n different space-separated strings).So, for n = 3 and the variable ordering x3, x1, x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0's and 1's over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character.The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA (x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

Output

For each S-tree, output the line ``S-Tree #j:", where j is the number of the S-tree. Then print a line that contains the value of UVA 712 (13.08.23)for each of the given m VVAs, where f is thefunction defined by the S-tree.

Output a blank line after each test case.

Sample Input

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

Sample Output

S-Tree #1:
0011

S-Tree #2:
0011


题意及做法:

变相的遍历题, 先输入层数n, 然后n个次序(后来证明, 这个输入是废物)

接着就是最后的一层叶子结点 (叶子结点的个数, 其实就是2的n次方)

然后输入一个数m, 代表m次遍历

随后的m行是遍历指令, 0代表往左, 1代表往右~

把m次遍历得到的结果保存下来一次性输出!


要点:

用数组存树的话, 设结点编号是k, 左儿子编号则为2*k, 右儿子编号为2*k+1;

我是一开始就把k设为1, 求出最后叶子结点的编号, 注意了, 此时的编号k不是在数组中的下标, 要减去上面结点数才行


AC代码:

#include<stdio.h>
#include<string.h>

char order[10][5];
char node[512];
char ans[10000];

int main() {
    int n;
    int cas = 0;
    while(scanf("%d", &n) != EOF && n) {
        int i, j;
        int presum = 1;
        for(i = 0; i < n; i++) {
            scanf("%s", order[i]);
            presum = presum * 2;
        }

        getchar();
        gets(node);

        int m;
        scanf("%d", &m);
        getchar();

        int pos = 0;
        char tmp[10];
        for(i = 0; i < m; i++) {
            gets(tmp);
            int len = strlen(tmp);
            int k = 1;
            for(j = 0; j < len; j++) {
                if(tmp[j] == '0')
                    k = 2*k;
                else
                    k = 2*k+1;
            }
            k = k - presum;
            ans[pos++] = node[k];
        }
        ans[pos] = '\0';
        printf("S-Tree #%d:\n", ++cas);
        puts(ans);
        printf("\n");
    }
    return 0;
}