欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

F时分秒转换

程序员文章站 2024-03-18 21:46:34
...

Problem F:时分秒转换

题目描述
输入秒表的计时s,将s的值转换为小时、分钟、秒

样例输入

6789

样例输出

1:53:09

答案

#include <stdio.h>
#include <math.h>
int main(){
    int t,th,tm,ts;
    scanf("%d",&t);
    th=t/3600;
    tm=(t-th*3600)/60;
    ts=t-th*3600-tm*60;
    printf("%d:%02d:%02d\n",th,tm,ts);       
}