欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1022. Digital Library (30)

程序员文章站 2024-03-17 21:55:58
...

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意:

数字图书馆中有数以百万计的书籍,根据书的书名、作者、他们的摘要、出版商和出版日期的关键字来储存。每一本书都有一个唯一的7位数字作为他的ID。给定读者的查询,你的任务是按照ID序列输出查询到的书籍。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正整数N(<=10000),表示书的总数。然后接下来是N本书,每本书都包含6行信息:
第1行:7位数字的ID号;
第2行:书名--一个不超过80个字符的字符串;
第3行:作者--一个不超过80个字符的字符串;
第4行:关键字--每个单词都是不超过10个字符的字符串,没有空格,关键字只被一个空格隔开;
第5行:发布者--一个不超过80个字符的字符串;
第6行:出版日期--一个4位数,范围[1000,3000].
假设每本书只属于只属于一个作者,包含不超过5个关键字;总数不超过1000不同的关键字个;而且不超过1000家不同的出版商。
在图书信息之后,有一行包含一个正整数M(<=1000),这是用户搜索查询的数量。然后接下来是M行,每一行格式如下:
1:一个书名。
2:作者姓名。
3:一个关键字。
4:出版商的名字。
5:一个4位数字代表一年。
输出规范:
对于每个查询,首先在一行中打印出原始查询,然后按升序输出结果图书的ID,每个占用一行,如果没有找到书,打印“Not Found”。

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
    char ID[10];
    char title[100];
    char author[100];
    char keywords[100];
    char publisher[100];
    char publishedyear[10];
}libary[10001];
int cmp(const void *a,const void *b)
{
    return strcmp((*(node *)a).ID,(*(node *)b).ID)>0?1:-1;
}
int main()
{
    int i,j,n,m,k,t,flag;
    char str[100],c;
    scanf("%d",&n);
    getchar();
    for(i=0;i<n;i++)
    {
        gets(libary[i].ID);
        gets(libary[i].title);
        gets(libary[i].author);
        gets(libary[i].keywords);
        gets(libary[i].publisher);
        gets(libary[i].publishedyear);
    }
    qsort(libary,n,sizeof(libary[0]),cmp);
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%d: ",&k);
        gets(str);
        printf("%d: %s\n",k,str);
        flag=0;
        for(j=0;j<n;j++)
        {
            if(strcmp(str,libary[j].title)==0)
            {
               printf("%s\n",libary[j].ID);
               flag=1;
            }
            else if(strcmp(str,libary[j].author)==0)
            {
                printf("%s\n",libary[j].ID);
                flag=1;
            }
            else if(strcmp(str,libary[j].publisher)==0)
            {
                printf("%s\n",libary[j].ID);
                flag=1;
            }
            else if(strcmp(str,libary[j].publishedyear)==0)
            {
                printf("%s\n",libary[j].ID);
                flag=1;
            }
            else if(strstr(libary[j].keywords,str)!=NULL)
            {
                printf("%s\n",libary[j].ID);
                flag=1;
            }
        }
        if(flag==0)
        {
            printf("Not Found\n");
        }
    }
    return 0;
}

错误代码:

感觉这样做应该可以啊,不知道哪错了,求大神告知。。。。。。

1022. Digital Library (30)

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
    char ID[10];
    char title[100];
    char author[100];
    char keywords[100];
    char publisher[100];
    int publishedyear;
}libary[10001];
int cmp(const void *a,const void *b)
{
    return strcmp((*(node *)a).ID,(*(node *)b).ID)>0?1:-1;
}
int main()
{
    int i,j,n,m,k,t,flag;
    char str[100],c;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        getchar();
        gets(libary[i].ID);
        gets(libary[i].title);
        gets(libary[i].author);
        gets(libary[i].keywords);
        gets(libary[i].publisher);
        scanf("%d",&libary[i].publishedyear);
    }
    qsort(libary,n,sizeof(libary[0]),cmp);
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%d",&k);
        getchar();
        getchar();
        switch(k)
        {
        case 1:
            gets(str);
            flag=0;
            printf("%d: %s\n",k,str);
            for(j=0;j<n;j++)
            {
                if(strcmp(str,libary[j].title)==0)
                    {
                        printf("%s\n",libary[j].ID);
                        flag=1;
                    }
            }
            if(flag==0)
                printf("Not Found\n");
            break;
        case 2:
            gets(str);
            flag=0;
            printf("%d: %s\n",k,str);
            for(j=0;j<n;j++)
            {
                if(strcmp(str,libary[j].author)==0)
                    {
                        printf("%s\n",libary[j].ID);
                        flag=1;
                        }
            }
            if(flag==0)
                printf("Not Found\n");
            break;
        case 3:
            gets(str);
            flag=0;
            printf("%d: %s\n",k,str);
            for(j=0;j<n;j++)
            {
                if(strstr(libary[j].keywords,str)!=NULL)
                    {
                        printf("%s\n",libary[j].ID);
                        flag=1;
                    }
            }
            if(flag==0)
                printf("Not Found\n");
            break;
        case 4:
            gets(str);
            flag=0;
            printf("%d: %s\n",k,str);
            for(j=0;j<n;j++)
            {
                if(strcmp(str,libary[j].publisher)==0)
                    {
                        printf("%s\n",libary[j].ID);
                        flag=1;
                    }
            }
            if(flag==0)
                printf("Not Found\n");
            break;
        case 5:
            scanf("%d",&t);
            flag=0;
            printf("%d: %d\n",k,t);
            for(j=0;j<n;j++)
            {
                if(libary[j].publishedyear==t)
                    {
                        printf("%s\n",libary[j].ID);
                        flag=1;
                    }
            }
            if(flag==0)
                printf("Not Found\n");
            break;
        }
    }
    return 0;
}