关于C++二分查找
程序员文章站
2024-03-17 21:43:22
...
M--二分查找
Time Limit: 600MS Memory Limit: 65536KB
Problem Description
给出含有n个数的升序序列,保证序列中的数两两不相等,这n个数编号从1 到n。
然后给出q次询问,每次询问给出一个数x,若x存在于此序列中,则输出其编号,否则输出-1。
Input
单组输入。首先输入一个整数n(1 <= n && n <= 3000000),接下的一行包含n个数。
再接下来的一行包含一个正整数q(1 <= q && q <= 10000),表示有q次询问。
再接下来的q行,每行包含一个正整数x。
Output
对于每次询问,输出一个整数代表答案。
Example Input
5 1 3 5 7 9 3 1 5 8
Example Output
1 3 -1
二分查找是非常快速的,但是在很多数的情况下容易超时,这是因为C++中cin以及cout的时间比较慢,所以我们需要在main函数中加入
std::ios::sync_with_studio(false);
这样一句话来取消cin、cout的同步
下面 答案来啦:
#include <bits/stdc++.h>
using namespace std;
int main()
{
std::ios::sync_with_stdio(false);
int n;int *a=new int[3000000];
cin>>n;
for(int i=0;i<n;i++)
{
cin>>a[i];
}
int m;cin>>m;
while(m--)
{
int flag=1;
int d;cin>>d;
int l=0,h=n-1,mid;
while(l<=h)
{
mid=(l+h)/2;
if(d>a[mid])
{
l=mid+1;
}
else if(d<a[mid])
{
h=mid-1;
}
else
{
flag=0;
cout<<mid+1<<endl;
break;
}
}
if(flag)
cout<<"-1"<<endl;
}
return 0;
}
上一篇: 知乎爬虫及数据分析(超大量)
下一篇: 多种方式实现strlen