欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Einbahnstrasse HDU - 2923 (SPFA最短路双向)

程序员文章站 2024-03-17 10:01:58
...

Einbahnstra Einbahnstrasse HDU - 2923 (SPFA最短路双向) e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.) 

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats: 


A -v -> B 
A <-v - B 
A <-v -> B 


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .) 

The test case in the example below is the same as the one in the figure. 

Einbahnstrasse HDU - 2923 (SPFA最短路双向)

Output

For each test case, print the total distance traveled using the following format: 


k . V 


Where k is test case number (starting at 1,) is a space, and V is the result.

Sample Input

4 2 5
NewTroy Midvale Metrodale
NewTroy   <-20-> Midvale
Midvale   --50-> Bakerline
NewTroy    <-5-- Bakerline
Metrodale <-30-> NewTroy
Metrodale  --5-> Bakerline
0 0 0

Sample Output

1. 80

题意:

给你拖车公司的地点和c辆破车的地点,问你从拖车公司出发把破车全部拖回拖车公司所走的最短路程(来回),

每次只能拖一辆车,回到公司把车放下后才能继续拖下一辆

输入

1. 一共n个地点,c辆破车,r条路线

2.第一个地点是拖车公司,其余c个地点是破车所在地

3 .接下来r条路线:  <- w->为双向 ,  --w->和<-w--为单向

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<map>
#include<queue>

using namespace std;

#define pb push_back
const int INF = 0x3f3f3f3f;
int car[2010], a1[110][110], a2[110][110], in[110], dis[110];
map<string, int> mp;

void SPFA(int a[][110], int n) {
	queue<int> q;
	memset(in, 0, sizeof(in));
	memset(dis, 0x3f, sizeof(dis));
	q.push(1);
	in[1] = 1;
	dis[1] = 0;
	while (!q.empty()) {
		
		int u = q.front();
		for (int i = 1; i <= n; ++i) {
			if(a[u][i] < INF && dis[i] > dis[u] + a[u][i]) {
				dis[i] = dis[u] + a[u][i];
				if (!in[i]) {
					q.push(i);
					in[i] = 1;
				}
			}
		}
		in[u] = 0;
		q.pop();
		
	}
}

int main(void) {
	
	int n, c, r, t = 0;
	while (~scanf("%d %d %d", &n, &c, &r) && (n + c + r)) {
		mp.clear();
		string name;
		memset(car, 0, sizeof(car));
		memset(a1, 0x3f, sizeof(a1)); //正向 
		memset(a2, 0x3f, sizeof(a2)); //反向 
		for (int i = 1; i <= n; ++i) a1[i][i] = a2[i][i] = 0;
		int cnt = 0;
		char str[15];
		scanf("%s", str);
		name = str;
		mp[name] = ++cnt;
		for (int i = 1; i <= c; ++i) {
			scanf("%s", str);
			name = str;
			if (!mp[name]) mp[name] = ++cnt;
			++car[mp[name]]; // 因为c>n所以一个地方可能有多辆车 
		}
		char ptr1[15], ptr2[15], d[15], c1, c2;
		string to;
		int w;
		for (int i = 1; i <= r; ++i) {
			scanf("%s %s %s", ptr1, d, ptr2);
			sscanf(d, "%c%*c%d%*c%c", &c1, &w, &c2); //正则表达式 
			name = ptr1, to = ptr2;
			int u = mp[name];
			int v = mp[to];
			if (!u) mp[name] = u = ++cnt;
			if (!v) mp[to] = v = ++cnt;
			if (c1 == '<' && a1[v][u] > w) // 可能有多条路:( 
			a1[v][u] = a2[u][v] = w;
			if (c2 == '>' && a1[u][v] > w)
			a1[u][v] = a2[v][u] = w;
			//printf("[ %d %d %d ]\n", u, v, w);
		}
		long long ans = 0;
 		SPFA(a1, cnt);
 		for (int i = 1; i <= cnt; ++i) {
 			if(car[i] > 0) {
 				ans += (dis[i] * car[i]); // 每次只能拖一辆  //去的路程 
			}
		}
		SPFA(a2, cnt);
		for (int i = 1; i <= cnt; ++i) {
			if(car[i] > 0) {
				ans += (dis[i] * car[i]); // 回的路程 
			}
		}
		printf("%d. %lld\n", ++t, ans);
	}
	
	return 0;
}