欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU 2923 Einbahnstrasse 【Floyd+map】

程序员文章站 2024-03-17 09:57:04
...

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3803 Accepted Submission(s): 1217

Problem Description

Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company’s garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company’s garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company’s garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

Input

Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company’s garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company’s garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:

A -v -> B
A <-v - B
A <-v -> B

A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , “the arrow”, and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.


HDU 2923 Einbahnstrasse 【Floyd+map】

Output

For each test case, print the total distance traveled using the following format:

k . V

Where k is test case number (starting at 1,) is a space, and V is the result.

Sample Input

4 2 5
NewTroy Midvale Metrodale
NewTroy <-20-> Midvale
Midvale –50-> Bakerline
NewTroy <-5– Bakerline
Metrodale <-30-> NewTroy
Metrodale –5-> Bakerline
0 0 0

Sample Output

  1. 80

提议概括:

  拖车需要从公司出发将所有城市的破车拖回到车库,每次只能拖一辆破车。题目保证可以到达所有破车所在城市。

解题分析:

  同一个城市可能有很多个破车,两个城市之间可能有多条道路,要选最短的。也可能存在A到B本来是双向路,距离为x,但可能有一条路是从B到A且距离比x小,这时就需要更新距离。因为城市名是英文,可以用STl中的map函数,对城市进行标号。

AC代码:

#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<stdio.h>
#include<algorithm>
using namespace std;

#define N 115
#define inf 99999999

int e[N][N];

void Floyd(int n)
{
    int i, j, k;
    for(k = 1; k <= n; k++){
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                if(e[i][j] > e[i][k]+e[k][j])
                    e[i][j] = e[i][k]+e[k][j];
    }
}

int main()
{
    int i, j, n, c, t, sum, num, l = 1, x, y;
    char s1[N], s2[N], from, to;
    int f[1005];
    map<string, int> mp;
    while(scanf("%d%d%d", &n, &c, &t), n || c || t){
        for(i = 1; i <= n; i++){
            for(j = 1; j <= n; j++)
                e[i][j] = inf;
            e[i][i] = 0;
        }
        mp.clear();
        j = 1;
        for(i = 0; i <= c; i++){
            scanf("%s", s1);
            if(!mp[s1]) mp[s1] = j++;
            f[i] = mp[s1];
        }
        while(t--){
            scanf("%s %c-%d-%c %s", s1, &from, &num, &to, s2);
            if(!mp[s1]) mp[s1] = j++;
            if(!mp[s2]) mp[s2] = j++;
            x = mp[s1];
            y = mp[s2];
            if(to == '>' && e[x][y]>num)
                e[x][y] = num;
            if(from == '<' && e[y][x]>num)
                e[y][x] = num;
        }
        Floyd(n);
        sum = 0;
        for(i = 1; i <= c; i++)
            sum += e[1][f[i]] + e[f[i]][1];
        printf("%d. %d\n", l++, sum);
    }
    return 0;
}
相关标签: floyd算法 map-c++