1256: 奇数检测
程序员文章站
2024-03-16 16:09:34
...
题目
Description
一个数组存放若干整数,只有一个数出现奇数次,其余数均出现偶数次,找出这个出现奇数次的数?
Input
输入中第一行为一个整数T(1 ≤ T ≤ 10),描述后面一共有T组测试数据。每组测试数据的第一个数为数组的长度n ( n > 0 ),跟着n个数据为数组元数。
Output
输出每组数据中出现奇数次的数。
Sample Input
3
5 5 5 5 5 6
7 1 1 2 4 2 3 3
1 1
Sample Output
6
4
1
代码块
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cn = new Scanner(System.in);
int t= cn.nextInt();
while(t-->0){
int n = cn.nextInt();
int[] z = new int[n];
for(int i =0;i<n;i++){
z[i] = cn.nextInt();
}
for(int i =0;i<n;i++){
int count = 0;
if(z[i]<0) continue;
for(int j = i+1 ;j<n;j++){
if(z[j]<0) continue;
if(z[i]==z[j]){
count++;
z[j] = -1;
}
}
if(count%2==0) {
System.out.println(z[i]);
break;
}
}
}
}
}