算法训练-ALGO-67 最大值与最小值的计算
程序员文章站
2024-03-15 21:39:30
...
输入11个整数,计算它们的最大值和最小值。
样例输入
0 1 2 3 4 5 6 7 8 9 10
样例输出
10 0
思路:通过Arrays.sort()进行排序然后输出第一个值和最后一个值.
package net.jichu;
import java.util.Arrays;
import java.util.Scanner;
/**
*
* @author
*最大值最小值的计算
*/
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int[] a = new int[11];
for(int i=0;i<a.length;i++){
a[i] = sc.nextInt();
}
Arrays.sort(a);
System.out.print(a[10]);
System.out.print(" ");
System.out.println(a[0]);
}
}