欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

字符串统计

程序员文章站 2024-02-27 15:11:45
...

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

 

 

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

 

 

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

 

 

Sample Input

 

2

asdfasdf123123asdfasdf

asdf111111111asdfasdfasdf

 

 

Sample Output

 

6

9

 

 

#include<stdio.h>
#include<string.h>
#include<Windows.h>
int main ()
{
int t;
char a[1000];
scanf("%d",&t);
while (t--)
{int i,sum=0;
scanf("%s",&a);

for (i=0;i<strlen(a);i++)
	if(a[i]>=48&&a[i]<=57) sum+=1;
printf("%d\n",sum);
}
system("pause");
return 0;
}