欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

ISIS的综合实验

程序员文章站 2024-02-15 21:00:10
...

示例图

一.实验目的

1.配置ISISNET
2.手动指定ISIS的Level 
3.手动指定ISIS的cost(基于全局的,基于接口的)
4.配置接口的网络类型
5.对引入的外部路由进行聚合
6.对在ISIS本地的路由进行聚合
7.把Level 2中的路由引入Level 1(路由渗透)

二.注意事项

1.骨干区域中的路由器,拥有,全网的路由条目(使能ISIS的接口IP地址)
2.非骨干区域中的路由器,拥有本区域中的所有路由条目(使能ISIS的接口IP地址)
3.如果一个区域,有两个Level-1-2路由器,那么本区域的其它路由会,拥有两条
   默认路由,在开销值相同时,分别指向不同的下一跳
4.在开销值不同时,默认路由的下一跳会指向开销值小的,下一跳
5.在不同位置,配置cost的优先级,基于接口>基于全局的>自动计算的>默认的
6.network-entity 49.0002    .0000.0000.0001  .00   OSI网络中为01
                 区域面积     System IDTCP/IP网络中总为00

三.简单配置

AR1

sysname AR1
#
isis 1
 is-level level-2
 network-entity 49.0002.0000.0000.0001.00
#
interface Serial4/0/0
 link-protocol ppp  
 //更改链路的网络类型为P2P
 ip address 10.0.12.1 255.255.255.0 
 isis enable 1
 isis circuit-level level-2  
 //链路的Level级别为Level 2默认为Level 1与2
 isis cost 15
 //更改此接口的开销值为15
#
interface GigabitEthernet0/0/0
 ip address 10.0.15.1 255.255.255.0 
 isis enable 1
 isis circuit-type p2p
 isis circuit-level level-2
#
interface GigabitEthernet0/0/1
 ip address 10.0.13.1 255.255.255.0 
 isis enable 1
 isis circuit-level level-2
#
interface LoopBack1
 ip address 1.1.1.1 255.255.255.0 
 isis enable 1
#
return

AR2

sysname AR2
#
isis 1
 circuit-cost 20
 network-entity 49.0001.0000.0000.0002.00
 import-route isis level-2 into level-1
 //把Level-2中的路由渗透Level-1中(路由渗透)
#
interface Serial2/0/0
 link-protocol ppp //因为为串行链路,默认的协议为PPP
 ip address 10.0.12.2 255.255.255.0 
 isis enable 1
#
interface GigabitEthernet0/0/0
 ip address 10.0.234.2 255.255.255.0 
 isis enable 1
#
interface LoopBack1
 ip address 2.2.2.2 255.255.255.0 
 isis enable 1
#
return

AR3

sysname AR3
#
isis 1
 network-entity 49.0001.0000.0000.0003.00
 import-route isis level-2 into level-1
#
interface GigabitEthernet0/0/0
 ip address 10.0.234.3 255.255.255.0 
 isis enable 1
#
interface GigabitEthernet0/0/1
 ip address 10.0.13.3 255.255.255.0 
 isis enable 1
#
interface LoopBack1
 ip address 3.3.3.3 255.255.255.0 
 isis enable 1
#
return

AR4

sysname AR4
#
isis 1
 is-level level-1
 network-entity 49.0001.0000.0000.0004.00
 summary 172.16.0.0 255.255.252.0 level-1
 //对在level-1中的路由进行路由聚合
#
interface GigabitEthernet0/0/0
 ip address 10.0.234.4 255.255.255.0 
 isis enable 1
#
interface LoopBack1
 ip address 4.4.4.4 255.255.255.0 
 isis enable 1
#
interface LoopBack2
 ip address 172.16.1.1 255.255.255.0 
 isis enable 1
#
interface LoopBack3
 ip address 172.16.2.1 255.255.255.0 
 isis enable 1
#
interface LoopBack4
 ip address 172.16.3.1 255.255.255.0 
 isis enable 1
#
return

AR5

sysname AR5
#
isis 1
 is-level level-2
 network-entity 49.0002.0000.0000.0005.00
 import-route direct 
 //引入外部路由,默认引入到Level-2中
 summary 192.168.0.0 255.255.252.0
 //对引入的路由进行聚合,默认是Level-2中的路由
#
interface GigabitEthernet0/0/0
 ip address 10.0.15.5 255.255.255.0 
 isis enable 1
 isis circuit-type p2p
#
interface LoopBack1
 ip address 5.5.5.5 255.255.255.0 
 isis enable 1
#
interface LoopBack2
 ip address 192.168.1.1 255.255.255.0 
#
interface LoopBack3
 ip address 192.168.2.1 255.255.255.0 
#
interface LoopBack4
 ip address 192.168.3.1 255.255.255.0 
return