1071 Speech Patterns (25 分)
1071 Speech Patterns (25 分)
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.
Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
Sample Input:
Can1: “Can a can can a can? It can!”
Sample Output:
can 5
Note
- 题意: 统计一句话中出现次数最多的单词
- 思路: 用不是数字和单词的地方分割, 每一个子串用map存,遍历map获得最大的次数
- 问题:
- map存储不能简单理解位数组,find不到的初值并不是零
- 漏掉整句话没有分割点的情况
Code
#include<iostream>
#include<map>
#include<string>
using namespace std;
map <string, int> m;
string s1;
int main(){
getline(cin, s1);
int len = s1.length();
int start = 0;
while(start < len){
if(!(((s1[start] >= 'a' && s1[start] <= 'z')|| (s1[start] >= 'A' && s1[start] <= 'Z') || s1[start] >= '0' && s1[start] <= '9')))
start ++;
else break;
}
int i;
for(i = start; i < len; i++){
if(s1[i] >= 'A' && s1[i] <= 'Z')
s1[i] += 'a' - 'A';
if(!((s1[i] >= 'a' && s1[i] <= 'z') || (s1[i] >= '0' && s1[i] <= '9'))){
string temp = s1.substr(start, i - start);
if(m.find(temp) != m.end()) m[temp] ++;
else m[temp] = 1;
start = i + 1;
}
}
if(start == 0 && i == len) {cout << s1 <<" " << "1"; return 0;}
string resultword;
int resultnum = 0;
for(auto it = m.begin(); it != m.end(); it++){
if(it -> second > resultnum && it -> first != ""){
resultword = it -> first;
resultnum = it -> second;
}
}
cout << resultword << " "<< resultnum;
return 0 ;
}
上一篇: 有一个关于数据表设计的问题