POJ 2488 A Knight's Journey (DFS深搜)
程序员文章站
2024-02-11 17:18:46
...
A Knight's Journey
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 45901 | Accepted: 15624 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
123
题目大意: 走日字形 能否走完这个圆 可以 字典序输出
日字形 走法:
注意 方向的问题
#include <iostream>
#include <queue>
#include <string>
#include <cstring>
#include <stdio.h>
#include <cmath>
using namespace std;
/*
日字形 从(1,1) 开始, 并且 行为数字, 列为字母, 字典序 先记录列 后行
*/
const int N =100;
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};// 注意顺序
int vis[N][N];
int maps[N][N];
int p,q,ans;
int flag;
bool judge(int x,int y)
{
if(x>=1&&x<=p&&y>=1&&y<=q&&!vis[x][y]&&!flag)
return true;
return false;
}
void dfs(int x,int y,int step)
{
maps[step][0]=x;
maps[step][1]=y;
if(step==p*q)
{
flag =1;
return;
}
for(int i=0;i<8;i++)
{
int px=x+dir[i][0];
int py=y+dir[i][1];
if(judge(px,py))
{
vis[px][py]=1;
dfs(px,py,step+1);
vis[px][py]=0;
}
}
}
int main()
{
int T,cont=0;
cin>>T;
while(T--)
{
flag=0;
cin>>p>>q;
memset(vis,0,sizeof(vis));
vis[1][1]=1;
dfs(1,1,1);
printf("Scenario #%d:\n",++cont);
if(!flag)
printf("impossible");
else
{
for(int i = 1; i <= p * q; i++)
printf("%c%d",maps[i][1] - 1 + 'A',maps[i][0]);// 先列后行 列 字母 行数字
}
printf("\n");
if(T!=0)
printf("\n");
}
return 0;
}
推荐阅读
-
POJ 2488 A Knight's Journey(DFS、记录路径)
-
POJ 2488 A Knight's Journey (DFS深搜)
-
POJ-2488,A Knight's Journey(DFS)
-
[POJ2488]A Knight's Journey(DFS)
-
poj-2488 A Knight's Journey
-
POJ-2488 A Knight's Journey
-
poj-2488 a knight's journey(搜索题)
-
poj-2488 a knight's journey(搜索题)
-
A - A Knight's Journey (poj2488)(dfs经典)